Repositoryexception while retry updating documents in master repository

What solved for me was to use the zip version instead: Software Updates, then select the Available Software tab and click the Manage Sites button Use the Export button to export the sites to a file Open the file in your favorite text editor, and add a trailing “/” to any of the site urls which are missing the “/” or remove on the end. Back in the Manage Sites window within Eclipse, select all of the sites and click the Remove button Now, click Import and load in the edited file For Oxygen, see Eclipse Community Forums: "In my case Oxygen had update URL for Buidship as: Note: that e46 is Neon version per https://github.com/eclipse/buildship/blob/master/docs/user/once I updated URL to Oxygen version (e47): update was successful" I am using lubuntu( like ubuntu) and I found that when I install ccs, I used sudo cmd, so some file can't be changed by another user, that's why the problem comes up.

So in the place I installed ccs, I run the cmd For me I had Spring IDE installed on Eclipse Oxygen.

However I did find this link: Basically, there seems to be a problem when an available update site doesn't have a trailing '/' in its link.

I'm running Eclipse's Helios EE bundle on Linux, to which I added the subversive plugins, the m2e maven integration and the mylin connector for Trac.

Deleting the cache folder in /Users/myname/.eclipse/org.eclipse.oomph.p2 solved the problem (my coworker, not me, came up with this solution) I had the same problem on windows 10.

My eclipse version was installed from an exe, downloaded from eclipse site.

As the most upvoted suggestion here, many of the suggestions are contradicting, suggesting trial-error guesses.

repositoryexception while retry updating documents in master repository-50repositoryexception while retry updating documents in master repository-10repositoryexception while retry updating documents in master repository-33repositoryexception while retry updating documents in master repository-75

Note: a link to this dialog is also available in the Install New Software dialog. No repository found containing: osgi.bundle,oracle.eclipse.lib,8.4.0.201510191754 For Eclipse Neon I had the mentioned error for Mylyn.Oh and sometimes this helps: Uncheck some options (like OSGI in your case).On Juno (Build id: 20130225-0426), exporting update sites from 'Available software Sites", fixing the trailing "/" in the exported xml as described above, removing all sites and importing the fixed xml worked for me.After saving, updating Mylyn and restarting eclipse, the Available Software Sites looked like this: Probably, my experience with this bug will be needed for someone (including myself too... So, I could to add one thing to the mentioned here answers.I mean playing with the trailing "/" symbol in the options, because playing with it does not work in my case.

Leave a Reply